Vulnerability · Published Jan 6, 2022 · Assigned by GitHub_M

CVE-2022-21662Stored XSS in WordPress

High 8.0

In plain English

A high-severity cross-site scripting in wordpress-develop from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 64.5% (higher than 99.2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)64.5%top 0.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Low-privileged authenticated users (like author) in WordPress core are able to execute JavaScript/perform stored XSS attack, which can affect high-privileged users. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12wordpress5.8.3+dfsg1-1DEBIAN-CVE-2022-21662
Debian:13wordpress5.8.3+dfsg1-1DEBIAN-CVE-2022-21662
Debian:14wordpress5.8.3+dfsg1-1DEBIAN-CVE-2022-21662

Affected products (as reported)

VendorProductVersions
WordPress wordpress-develop < 5.8.3

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

References