Vulnerability · Published Jun 13, 2022 · Assigned by WPScan

CVE-2022-1791One Click Plugin Updater <= 2.4.14 - Arbitrary Settings Update via CSRF

High 8.1

In plain English

A high-severity cross-site request forgery in One Click Plugin Updater from Unknown. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities).

Severity (CVSS NVD)8.1High
Exploit odds (30 days)0.5%top 55.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The One Click Plugin Updater WordPress plugin through 2.4.14 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack and disable / hide the badge of the available updates and the related check.

Affected products (as reported)

VendorProductVersions
Unknown One Click Plugin Updater 2.4.14 – through 2.4.14

Weakness: CWE-352

References