Vulnerability · Published May 3, 2022 · Assigned by openssl
CVE-2022-1292The c_rehash script allows command injection
Critical 9.8
In plain English
A critical-severity OS command injection in OpenSSL from OpenSSL. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 82.6% (higher than 99.7% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
The c_rehash script does not properly sanitise shell metacharacters to prevent command injection. This script is distributed by some operating systems in a manner where it is automatically executed. On such operating systems, an attacker could execute arbitrary commands with the privileges of the script. Use of the c_rehash script is considered obsolete and should be replaced by the OpenSSL rehash command line tool. Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2). Fixed in OpenSSL 1.1.1o (Affected 1.1.1-1.1.1n). Fixed in OpenSSL 1.0.2ze (Affected 1.0.2-1.0.2zd).
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | openssl | 1:1.1.1k-7.el8_6 | ALSA-2022:5818 |
| AlmaLinux:9 | openssl | 1:3.0.1-41.el9_0 | ALSA-2022:6224 |
| AlmaLinux:8 | openssl-devel | 1:1.1.1k-7.el8_6 | ALSA-2022:5818 |
| AlmaLinux:9 | openssl-devel | 1:3.0.1-41.el9_0 | ALSA-2022:6224 |
| AlmaLinux:8 | openssl-libs | 1:1.1.1k-7.el8_6 | ALSA-2022:5818 |
| AlmaLinux:9 | openssl-libs | 1:3.0.1-41.el9_0 | ALSA-2022:6224 |
| AlmaLinux:8 | openssl-perl | 1:1.1.1k-7.el8_6 | ALSA-2022:5818 |
| AlmaLinux:9 | openssl-perl | 1:3.0.1-41.el9_0 | ALSA-2022:6224 |
| Alpine:v3.20 | openssl | 0 | ALPINE-CVE-2022-1292 |
| Alpine:v3.21 | openssl | 0 | ALPINE-CVE-2022-1292 |
| Alpine:v3.22 | openssl | 0 | ALPINE-CVE-2022-1292 |
| Alpine:v3.23 | openssl | 0 | ALPINE-CVE-2022-1292 |
| Alpine:v3.24 | openssl | 0 | ALPINE-CVE-2022-1292 |
| Debian:12 | openssl | 1.1.1o-1 | DEBIAN-CVE-2022-1292 |
| Debian:13 | openssl | 1.1.1o-1 | DEBIAN-CVE-2022-1292 |
| Debian:14 | openssl | 1.1.1o-1 | DEBIAN-CVE-2022-1292 |
| Rocky Linux:8 | openssl | 1:1.1.1k-7.el8_6 | RLSA-2022:5818 |
| Ubuntu:22.04:LTS | edk2 | 2022.02-3ubuntu0.22.04.3 | USN-7060-1 |
| Ubuntu:22.04:LTS | nodejs | 12.22.9~dfsg-1ubuntu3.1 | USN-6457-1 |
| Ubuntu:22.04:LTS | nodejs | 12.22.9~dfsg-1ubuntu3.1 | UBUNTU-CVE-2022-1292 |
| Ubuntu:22.04:LTS | openssl | 3.0.2-0ubuntu1.1 | USN-5402-1 |
| Ubuntu:22.04:LTS | openssl | 3.0.2-0ubuntu1.1 | UBUNTU-CVE-2022-1292 |
Affected products (as reported)
Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://www.openssl.org/news/secadv/20220503.txt
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=1ad73b4d27bd8c1b369a3cd453681d3a4f1bb9b2
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=e5fd1728ef4c7a5bf7c7a7163ca60370460a6e23
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=548d3f280a6e737673f5b61fce24bb100108dfeb
- [debian-lts-announce] 20220515 [SECURITY] [DLA 3008-1] openssl security update mailing-list
- DSA-5139 vendor-advisory
- FEDORA-2022-b651cb69e6 vendor-advisory
- FEDORA-2022-c9c02865f6 vendor-advisory
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://security.netapp.com/advisory/ntap-20220602-0009/
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2022-0011
- https://security.netapp.com/advisory/ntap-20220729-0004/
- GLSA-202210-02 vendor-advisory
- https://cert-portal.siemens.com/productcert/pdf/ssa-953464.pdf
- https://gitlab.com/fraf0/cve-2022-1292-re_score-analysis
- https://cert-portal.siemens.com/productcert/html/ssa-953464.html
- https://cert-portal.siemens.com/productcert/html/ssa-419740.html
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
- https://cert-portal.siemens.com/productcert/html/ssa-942865.html
- https://cert-portal.siemens.com/productcert/html/ssa-146325.html
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html