Vulnerability · Published Aug 29, 2022 · Assigned by redhat

CVE-2022-0336

High 8.8

In plain English

A high-severity incorrect default permissions in Samba. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 78% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)8.8High
Exploit odds (30 days)1.8%top 22.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The Samba AD DC includes checks when adding service principals names (SPNs) to an account to ensure that SPNs do not alias with those already in the database. Some of these checks are able to be bypassed if an account modification re-adds an SPN that was previously present on that account, such as one added when a computer is joined to a domain. An attacker who has the ability to write to an account can exploit this to perform a denial-of-service attack by adding an SPN that matches an existing service. Additionally, an attacker who can intercept traffic can impersonate existing services, resulting in a loss of confidentiality and integrity.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12samba2:4.16.0+dfsg-2DEBIAN-CVE-2022-0336
Debian:13samba2:4.16.0+dfsg-2DEBIAN-CVE-2022-0336
Debian:14samba2:4.16.0+dfsg-2DEBIAN-CVE-2022-0336

Affected products (as reported)

VendorProductVersions
n/a Samba Affects Samba v4.0.0 and later, Fixed in samba v4.13.17, v4.14.12, v4.15.4.

Weakness: CWE-276

References