Vulnerability · Published Feb 4, 2022 · Assigned by mitre
CVE-2021-46320
High 7.5
In plain English
A high-severity security flaw in the @openzeppelin/contracts package (npm). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In OpenZeppelin <=v4.4.0, initializer functions that are invoked separate from contract creation (the most prominent example being minimal proxies) may be reentered if they make an untrusted non-view external call. Once an initializer has finished running it can never be re-executed. However, an exception put in place to support multiple inheritance made reentrancy possible, breaking the expectation that there is a single execution.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @openzeppelin/contracts | 4.4.1 | GHSA-88g8-f5mf-f5rj |
| npm | @openzeppelin/contracts | 4.4.1 | GHSA-9c22-pwxw-p6hx |
| npm | @openzeppelin/contracts-upgradeable | 4.4.1 | GHSA-9c22-pwxw-p6hx |