Vulnerability · Published Feb 17, 2022 · Assigned by canonical

CVE-2021-44731snapd could be made to escalate privileges and run programs as administrator

High 7.8

In plain English

A high-severity race condition in snapd from Canonical Ltd.. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 61% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.8High
Exploit odds (30 days)1.0%top 38.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

A race condition existed in the snapd 2.54.2 snap-confine binary when preparing a private mount namespace for a snap. This could allow a local attacker to gain root privileges by bind-mounting their own contents inside the snap's private mount namespace and causing snap-confine to execute arbitrary code and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12snapd2.54.3-1DEBIAN-CVE-2021-44731
Debian:13snapd2.54.3-1DEBIAN-CVE-2021-44731
Debian:14snapd2.54.3-1DEBIAN-CVE-2021-44731

Affected products (as reported)

VendorProductVersions
Canonical Ltd. snapd unspecified – through 2.54.2

Weakness: CWE-362 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

References