Vulnerability · Published Feb 17, 2022 · Assigned by canonical

CVE-2021-44730snapd could be made to escalate privileges and run programs as administrator

High 7.8

In plain English

A high-severity security flaw in snapd from Canonical Ltd.. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.8High
Exploit odds (30 days)0.4%top 71.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

snapd 2.54.2 did not properly validate the location of the snap-confine binary. A local attacker who can hardlink this binary to another location to cause snap-confine to execute other arbitrary binaries and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12snapd2.54.3-1DEBIAN-CVE-2021-44730
Debian:13snapd2.54.3-1DEBIAN-CVE-2021-44730
Debian:14snapd2.54.3-1DEBIAN-CVE-2021-44730

Affected products (as reported)

VendorProductVersions
Canonical Ltd. snapd unspecified – through 2.54.2

Weakness: CWE-59 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

References