Vulnerability · Published Feb 1, 2022 · Assigned by apache
CVE-2021-44451API sensitive information leak
Medium 6.5
In plain English
A medium-severity security flaw in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 7.9% (higher than 95% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)6.5Medium
Exploit odds (30 days)7.9%top 5.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Nuclei
Official description
Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-superset | 1.4.0 | GHSA-hhm3-48h2-597v |
| PyPI | apache-superset | 1.4.0 | PYSEC-2022-36 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Superset | Apache Superset – through 1.3.2 |
Weakness: CWE-522
References
- https://lists.apache.org/thread/xww1pccs2ckb5506wrf1v4lmxg198vkb x_refsource_MISC