Vulnerability · Published Jul 18, 2023 · Assigned by VulDB
CVE-2021-4428what3words Autosuggest Plugin Setting class-w3w-autosuggest-public.php enqueue_scripts information disclosure
Low 2.7
In plain English
A low-severity information exposure in Autosuggest Plugin from what3words. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 15.8% (higher than 97% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.
Official description
A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vulnerability is the function enqueue_scripts of the file w3w-autosuggest/public/class-w3w-autosuggest-public.php of the component Setting Handler. The manipulation leads to information disclosure. The attack can be launched remotely. Upgrading to version 4.0.1 is able to address this issue. The patch is named dd59cbac5f86057d6a73b87007c08b8bfa0c32ac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-234247.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| what3words | Autosuggest Plugin | 4.0 |
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
References
- https://vuldb.com/?id.234247 vdb-entry, technical-description
- https://vuldb.com/?ctiid.234247 signature, permissions-required
- https://github.com/what3words/wordpress-autosuggest-plugin/pull/20 issue-tracking
- https://github.com/what3words/wordpress-autosuggest-plugin/commit/dd59cbac5f86057d6a73b87007c08b8bfa0c32ac patch
- https://github.com/what3words/wordpress-autosuggest-plugin/releases/tag/v4.0.1 patch