Vulnerability · Published Jan 5, 2022 · Assigned by GitHub_M

CVE-2021-43816Improper Preservation of Permissions in containerd

High 8.0

In plain English

A high-severity security flaw in containerd from containerd. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 79% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)1.8%top 21.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

containerd is an open source container runtime. On installations using SELinux, such as EL8 (CentOS, RHEL), Fedora, or SUSE MicroOS, with containerd since v1.5.0-beta.0 as the backing container runtime interface (CRI), an unprivileged pod scheduled to the node may bind mount, via hostPath volume, any privileged, regular file on disk for complete read/write access (sans delete). Such is achieved by placing the in-container location of the hostPath volume mount at either `/etc/hosts`, `/etc/hostname`, or `/etc/resolv.conf`. These locations are being relabeled indiscriminately to match the container process-label which effectively elevates permissions for savvy containers that would not normally be able to access privileged host files. This issue has been resolved in version 1.5.9. Users are advised to upgrade as soon as possible.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20containerd1.5.9-r0ALPINE-CVE-2021-43816
Alpine:v3.21containerd1.5.9-r0ALPINE-CVE-2021-43816
Alpine:v3.22containerd1.5.9-r0ALPINE-CVE-2021-43816
Alpine:v3.23containerd1.5.9-r0ALPINE-CVE-2021-43816
Alpine:v3.24containerd1.5.9-r0ALPINE-CVE-2021-43816
Debian:12containerd1.5.9~ds1-1DEBIAN-CVE-2021-43816
Debian:13containerd1.5.9~ds1-1DEBIAN-CVE-2021-43816
Debian:14containerd1.5.9~ds1-1DEBIAN-CVE-2021-43816
Gogithub.com/containerd/containerd1.5.9GHSA-mvff-h3cj-wj9c
Gogithub.com/containerd/containerd1.5.9GO-2022-0278
Ubuntu:22.04:LTScontainerd1.5.9-0ubuntu1UBUNTU-CVE-2021-43816

Affected products (as reported)

VendorProductVersions
containerd containerd >= 1.5.0, < 1.5.9

Weakness: CWE-281 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

References