Vulnerability · Published Dec 9, 2021 · Assigned by GitHub_M

CVE-2021-41265Improper Authentication in Flask-AppBuilder

High 8.1

In plain English

A high-severity improper authentication in Flask-AppBuilder from dpgaspar. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)1.3%top 29.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Flask-AppBuilder is a development framework built on top of Flask. Verions prior to 3.3.4 contain an improper authentication vulnerability in the REST API. The issue allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. This only affects non database authentication types and new REST API endpoints. Users should upgrade to Flask-AppBuilder 3.3.4 to receive a patch.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIflask-appbuilder3.3.4GHSA-m3rf-7m4w-r66q
PyPIflask-appbuilder3.3.4PYSEC-2021-851

Affected products (as reported)

VendorProductVersions
dpgaspar Flask-AppBuilder < 3.3.4

Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

References