Vulnerability · Published Nov 5, 2021 · Assigned by GitHub_M

CVE-2021-41230OIDC claims not updated from Identity Provider in Pomerium

Medium 5.3

In plain English

A medium-severity incorrect authorization in pomerium from pomerium. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.9%top 41.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Pomerium is an open source identity-aware access proxy. In affected versions changes to the OIDC claims of a user after initial login are not reflected in policy evaluation when using `allowed_idp_claims` as part of policy. If using `allowed_idp_claims` and a user's claims are changed, Pomerium can make incorrect authorization decisions. This issue has been resolved in v0.15.6. For users unable to upgrade clear data on `databroker` service by clearing redis or restarting the in-memory databroker to force claims to be updated.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/pomerium/pomerium0.15.6GHSA-j6wp-3859-vxfg
Gogithub.com/pomerium/pomerium0.15.6GO-2021-0258

Affected products (as reported)

VendorProductVersions
pomerium pomerium >= 0.14.0, < 0.15.6

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N

References