Vulnerability · Published Oct 6, 2021 · Assigned by GitHub_M
CVE-2021-41125HTTP authentication credential leak to target websites in scrapy
Medium 5.7
In plain English
A medium-severity information exposure in scrapy from scrapy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Scrapy is a high-level web crawling and scraping framework for Python. If you use `HttpAuthMiddleware` (i.e. the `http_user` and `http_pass` spider attributes) for HTTP authentication, all requests will expose your credentials to the request target. This includes requests generated by Scrapy components, such as `robots.txt` requests sent by Scrapy when the `ROBOTSTXT_OBEY` setting is set to `True`, or as requests reached through redirects. Upgrade to Scrapy 2.5.1 and use the new `http_auth_domain` spider attribute to control which domains are allowed to receive the configured HTTP authentication credentials. If you are using Scrapy 1.8 or a lower version, and upgrading to Scrapy 2.5.1 is not an option, you may upgrade to Scrapy 1.8.1 instead. If you cannot upgrade, set your HTTP authentication credentials on a per-request basis, using for example the `w3lib.http.basic_auth_header` function to convert your credentials into a value that you can assign to the `Authorization` header of your request, instead of defining your credentials globally using `HttpAuthMiddleware`.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | python-scrapy | 2.5.1-1 | DEBIAN-CVE-2021-41125 |
| Debian:13 | python-scrapy | 2.5.1-1 | DEBIAN-CVE-2021-41125 |
| Debian:14 | python-scrapy | 2.5.1-1 | DEBIAN-CVE-2021-41125 |
| PyPI | scrapy | 1.8.1 | GHSA-jwqp-28gf-p498 |
| PyPI | scrapy | 2.5.1 | GHSA-jwqp-28gf-p498 |
| PyPI | scrapy | 1.8.1, 2.5.1 | PYSEC-2021-363 |
Affected products (as reported)
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
References
- https://github.com/scrapy/scrapy/security/advisories/GHSA-jwqp-28gf-p498 x_refsource_CONFIRM
- https://github.com/scrapy/scrapy/commit/b01d69a1bf48060daec8f751368622352d8b85a6 x_refsource_MISC
- https://w3lib.readthedocs.io/en/latest/w3lib.html#w3lib.http.basic_auth_header x_refsource_MISC
- http://doc.scrapy.org/en/latest/topics/downloader-middleware.html#module-scrapy.downloadermiddlewares.httpauth x_refsource_MISC
- [debian-lts-announce] 20220316 [SECURITY] [DLA 2950-1] python-scrapy security update mailing-list, x_refsource_MLIST