Vulnerability · Published May 5, 2023 · Assigned by apache
CVE-2021-40331Permissions problem in the Apache Ranger Hive Plugin
High 8.1
In plain English
A high-severity incorrect permission assignment in Apache Ranger Hive Plugin from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin. Any user with SELECT privilege on a database can alter the ownership of the table in Hive when Apache Ranger Hive Plugin is enabled This issue affects Apache Ranger Hive Plugin: from 2.0.0 through 2.3.0. Users are recommended to upgrade to version 2.4.0 or later.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.ranger:ranger-hive-plugin | 2.4.0 | GHSA-vjr2-wpfh-5r9p |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Ranger Hive Plugin | 2.0.0 – through 2.3.0 |
Weakness: CWE-732 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
References
- https://lists.apache.org/thread/s68yls6cnkdmzn1k4hqt50vs6wjvt2rn vendor-advisory