Vulnerability · Published Sep 20, 2021 · Assigned by GitHub_M

CVE-2021-39229Regular expression deinal of service in apprise

High 7.5

In plain English

A high-severity uncontrolled resource consumption in apprise from caronc. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.9% (higher than 80% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.9%top 20.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is [here](https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359). The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove `apprise/plugins/NotifyIFTTT.py` to eliminate the service.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapprise0.9.5.1GHSA-qhmp-h54x-38qr
PyPIapprise0.9.5.1PYSEC-2021-327

Affected products (as reported)

VendorProductVersions
caronc apprise < 0.9.5.1

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References