Vulnerability · Published Sep 15, 2021 · Assigned by GitHub_M
CVE-2021-39210Autologin cookie accessible by scripts
Medium 6.5
In plain English
A medium-severity security flaw in glpi from glpi-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities).
Official description
GLPI is a free Asset and IT management software package. In versions prior to 9.5.6, the cookie used to store the autologin cookie (when a user uses the "remember me" feature) is accessible by scripts. A malicious plugin that could steal this cookie would be able to use it to autologin. This issue is fixed in version 9.5.6. As a workaround, one may avoid using the "remember me" feature.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| glpi-project | glpi | < 9.5.6 |
Weakness: CWE-1004 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/glpi-project/glpi/releases/tag/9.5.6 x_refsource_MISC
- https://github.com/glpi-project/glpi/security/advisories/GHSA-hwxq-4c5f-m4v2 x_refsource_CONFIRM
- https://huntr.dev/bounties/b2e99a41-b904-419f-a274-ae383e4925f2/ x_refsource_MISC