Vulnerability · Published Sep 9, 2021 · Assigned by GitHub_M

CVE-2021-39201Authenticated cross-site scripting (XSS) in WordPress editor

High 7.6

In plain English

A high-severity cross-site scripting in wordpress-develop from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 74% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.6High
Exploit odds (30 days)1.5%top 25.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. ### Impact The issue allows an authenticated but low-privileged user (like contributor/author) to execute XSS in the editor. This bypasses the restrictions imposed on users who do not have the permission to post `unfiltered_html`. ### Patches This has been patched in WordPress 5.8, and will be pushed to older versions via minor releases (automatic updates). It's strongly recommended that you keep auto-updates enabled to receive the fix. ### References https://wordpress.org/news/category/releases/ https://hackerone.com/reports/1142140 ### For more information If you have any questions or comments about this advisory: * Open an issue in [HackerOne](https://hackerone.com/wordpress)

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12wordpress5.8.1+dfsg1-1DEBIAN-CVE-2021-39201
Debian:13wordpress5.8.1+dfsg1-1DEBIAN-CVE-2021-39201
Debian:14wordpress5.8.1+dfsg1-1DEBIAN-CVE-2021-39201
Ubuntu:22.04:LTSwordpressno fix listedUBUNTU-CVE-2021-39201
Ubuntu:24.04:LTSwordpressno fix listedUBUNTU-CVE-2021-39201
Ubuntu:25.10wordpressno fix listedUBUNTU-CVE-2021-39201
Ubuntu:26.04:LTSwordpressno fix listedUBUNTU-CVE-2021-39201
Ubuntu:26.10wordpressno fix listedUBUNTU-CVE-2021-39201

Affected products (as reported)

VendorProductVersions
WordPress wordpress-develop >= 5.0, < 5.8.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N

References