Vulnerability · Published Aug 9, 2021 · Assigned by GitHub_M
CVE-2021-37619Out-of-bounds read in Exiv2::Jp2Image::encodeJp2Header
Medium 4.7
In plain English
A medium-severity out-of-bounds read in exiv2 from Exiv2. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.4 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as insert. The bug is fixed in version v0.27.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | compat-exiv2-026 | 0.26-6.el8 | ALSA-2021:4319 |
| AlmaLinux:8 | exiv2 | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-devel | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-doc | 0.27.4-5.el8 | ALSA-2021:4173 |
| AlmaLinux:8 | exiv2-libs | 0.27.4-5.el8 | ALSA-2021:4173 |
| Alpine:v3.20 | exiv2 | 0.27.5-r0 | ALPINE-CVE-2021-37619 |
| Alpine:v3.21 | exiv2 | 0.27.5-r0 | ALPINE-CVE-2021-37619 |
| Alpine:v3.22 | exiv2 | 0.27.5-r0 | ALPINE-CVE-2021-37619 |
| Alpine:v3.23 | exiv2 | 0.27.5-r0 | ALPINE-CVE-2021-37619 |
| Alpine:v3.24 | exiv2 | 0.27.5-r0 | ALPINE-CVE-2021-37619 |
| Debian:12 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-37619 |
| Debian:13 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-37619 |
| Debian:14 | exiv2 | 0.27.5-1 | DEBIAN-CVE-2021-37619 |
| Rocky Linux:8 | compat-exiv2-026 | 0:0.26-6.el8 | RLSA-2021:4319 |
| Rocky Linux:8 | exiv2 | 0:0.27.4-5.el8 | RLSA-2021:4173 |
| Ubuntu:22.04:LTS | exiv2 | 0.27.3-3ubuntu4 | UBUNTU-CVE-2021-37619 |
Affected products (as reported)
Weakness: CWE-125 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H
References
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-mxw9-qx4c-6m8v
- https://github.com/Exiv2/exiv2/pull/1752
- FEDORA-2021-399f869889 vendor-advisory
- FEDORA-2021-cbaef8e2d5 vendor-advisory
- GLSA-202312-06 vendor-advisory