Vulnerability · Published Jun 13, 2022 · Assigned by apache

CVE-2021-37404Heap buffer overflow in libhdfs native library

Critical 9.8

In plain English

A critical-severity out-of-bounds write in Apache Hadoop from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.1% (higher than 88% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)3.1%top 12.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.hadoop:hadoop-common3.3.2GHSA-rmpj-7c96-mrg8
Mavenorg.apache.hadoop:hadoop-common3.2.3GHSA-rmpj-7c96-mrg8
Mavenorg.apache.hadoop:hadoop-common2.10.2GHSA-rmpj-7c96-mrg8

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Hadoop 2.9.0 to 2.10.13.0.0 to 3.1.43.2.0 to 3.2.23.3.0 to 3.3.1

Weakness: CWE-787

References