Vulnerability · Published Aug 17, 2021 · Assigned by rapid7
CVE-2021-3619Rapid7 Velociraptor Notebooks Authenticated Persistent XSS
Low 3.5
In plain English
A low-severity cross-site scripting in Velociraptor from Rapid7. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities).
Official description
Rapid7 Velociraptor 0.5.9 and prior is vulnerable to a post-authentication persistent cross-site scripting (XSS) issue, where an authenticated user could abuse MIME filetype sniffing to embed executable code on a malicious upload. This issue was fixed in version 0.6.0. Note that login rights to Velociraptor is nearly always reserved for trusted and verified users with IT security backgrounds.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Rapid7 | Velociraptor | 0.5.9 – through 0.5.9 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
References
- https://github.com/Velocidex/velociraptor/pull/1118 x_refsource_MISC
- https://github.com/Velocidex/velociraptor/releases/tag/v0.6.0 x_refsource_CONFIRM