Vulnerability · Published Aug 12, 2021 · Assigned by mitre
CVE-2021-35955
Medium 4.8
In plain English
A medium-severity security flaw in the contao/contao package (Packagist). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)4.8Medium
Exploit odds (30 days)0.6%top 53.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | contao/contao | 4.4.56 | GHSA-hr3h-x6gq-rqcp |
| Packagist | contao/contao | 4.9.18 | GHSA-hr3h-x6gq-rqcp |
| Packagist | contao/contao | 4.11.7 | GHSA-hr3h-x6gq-rqcp |
| Packagist | contao/core-bundle | 4.4.56 | GHSA-hr3h-x6gq-rqcp |
| Packagist | contao/core-bundle | 4.9.18 | GHSA-hr3h-x6gq-rqcp |
| Packagist | contao/core-bundle | 4.11.7 | GHSA-hr3h-x6gq-rqcp |