Vulnerability · Published Aug 11, 2021 · Assigned by Wordfence
CVE-2021-34640Securimage-WP-Fixed <= 3.5.4 Reflected Cross-Site Scripting
Medium 6.1
In plain English
A medium-severity cross-site scripting in Securimage-WP-Fixed from Securimage-WP-Fixed. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.3% (higher than 83% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei.
Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)2.3%top 16.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Nuclei
Official description
The Securimage-WP-Fixed WordPress plugin is vulnerable to Reflected Cross-Site Scripting due to the use of $_SERVER['PHP_SELF'] in the ~/securimage-wp.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 3.5.4.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Securimage-WP-Fixed | Securimage-WP-Fixed | 3.5.4 – through 3.5.4 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N