Vulnerability · Published Mar 25, 2021 · Assigned by openssl

CVE-2021-3450CA certificate check bypass with X509_V_FLAG_X509_STRICT

High 7.4

In plain English

A high-severity security flaw in OpenSSL from OpenSSL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 18.3% (higher than 97% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.4High
Exploit odds (30 days)18.3%top 2.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

The X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20openssl1.1.1k-r0ALPINE-CVE-2021-3450
Alpine:v3.21openssl1.1.1k-r0ALPINE-CVE-2021-3450
Alpine:v3.22openssl1.1.1k-r0ALPINE-CVE-2021-3450
Alpine:v3.23openssl1.1.1k-r0ALPINE-CVE-2021-3450
Alpine:v3.24openssl1.1.1k-r0ALPINE-CVE-2021-3450
Debian:12openssl1.1.1k-1DEBIAN-CVE-2021-3450
Debian:13openssl1.1.1k-1DEBIAN-CVE-2021-3450
Debian:14openssl1.1.1k-1DEBIAN-CVE-2021-3450
Rocky Linux:8openssl1:1.1.1g-15.el8_3RLSA-2021:1024

Affected products (as reported)

VendorProductVersions
OpenSSL OpenSSL Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j)

References