Vulnerability · Published Sep 7, 2021 · Assigned by GitHub_M

CVE-2021-32802Preview generation used third-party library not suited for user-generated content in Nextcloud server

Critical 9.3

In plain English

A critical-severity security flaw in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.6% (higher than 85% of all known vulnerabilities).

Severity (CVSS 3.1)9.3Critical
Exploit odds (30 days)2.6%top 14.6% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Nextcloud server is an open source, self hosted personal cloud. Nextcloud supports rendering image previews for user provided file content. For some image types, the Nextcloud server was invoking a third-party library that wasn't suited for untrusted user-supplied content. There are several security concerns with passing user-generated content to this library, such as Server-Side-Request-Forgery, file disclosure or potentially executing code on the system. The risk depends on your system configuration and the installed library version. It is recommended that the Nextcloud Server is upgraded to 20.0.12, 21.0.4 or 22.1.0. These versions do not use this library anymore. As a workaround users may disable previews by setting `enable_previews` to `false` in `config.php`.

Affected products (as reported)

VendorProductVersions
nextcloud security-advisories < 20.0.12>= 21.0.0, < 21.0.4>= 22.0.0, < 22.1.0

Weakness: CWE-829 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L

References