Vulnerability · Published Jul 12, 2021 · Assigned by GitHub_M
CVE-2021-32733XSS in Nextcloud Text application
Medium 4.8
In plain English
A medium-severity cross-site scripting in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities).
Official description
Nextcloud Text is a collaborative document editing application that uses Markdown. A cross-site scripting vulnerability is present in versions prior to 19.0.13, 20.0.11, and 21.0.3. The Nextcloud Text application shipped with Nextcloud server used a `text/html` Content-Type when serving files to users. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. The issue was fixed in versions 19.0.13, 20.0.11, and 21.0.3. As a workaround, use a browser that has support for Content-Security-Policy.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | < 19.0.13>= 20.0.0, < 20.0.11>= 21.0.0, < 21.0.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-x4w3-jhcr-57pq x_refsource_CONFIRM
- https://github.com/nextcloud/text/pull/1689 x_refsource_MISC
- https://hackerone.com/reports/1241460 x_refsource_MISC