Vulnerability · Published Jun 24, 2021 · Assigned by GitHub_M

CVE-2021-32708Time-of-check Time-of-use (TOCTOU) Race Condition in league/flysystem

Critical 9.8

In plain English

A critical-severity security flaw in flysystem from thephpleague. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.5% (higher than 89% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)3.5%top 10.8% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

Flysystem is an open source file storage library for PHP. The whitespace normalisation using in 1.x and 2.x removes any unicode whitespace. Under certain specific conditions this could potentially allow a malicious user to execute code remotely. The conditions are: A user is allowed to supply the path or filename of an uploaded file, the supplied path or filename is not checked against unicode chars, the supplied pathname checked against an extension deny-list, not an allow-list, the supplied path or filename contains a unicode whitespace char in the extension, the uploaded file is stored in a directory that allows PHP code to be executed. Given these conditions are met a user can upload and execute arbitrary code on the system under attack. The unicode whitespace removal has been replaced with a rejection (exception). For 1.x users, upgrade to 1.1.4. For 2.x users, upgrade to 2.1.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12php-league-flysystem1.1.3-4DEBIAN-CVE-2021-32708
Debian:13php-league-flysystem1.1.3-4DEBIAN-CVE-2021-32708
Debian:14php-league-flysystem1.1.3-4DEBIAN-CVE-2021-32708
Packagistleague/flysystem1.1.4GHSA-9f46-5r25-5wfm
Packagistleague/flysystem2.1.1GHSA-9f46-5r25-5wfm
Ubuntu:22.04:LTSphp-league-flysystemno fix listedUBUNTU-CVE-2021-32708
Ubuntu:24.04:LTSphp-league-flysystemno fix listedUBUNTU-CVE-2021-32708
Ubuntu:25.10php-league-flysystemno fix listedUBUNTU-CVE-2021-32708
Ubuntu:26.04:LTSphp-league-flysystemno fix listedUBUNTU-CVE-2021-32708
Ubuntu:26.10php-league-flysystemno fix listedUBUNTU-CVE-2021-32708

Affected products (as reported)

VendorProductVersions
thephpleague flysystem < 1.1.4>= 2.0.0, < 2.1.1

Weakness: CWE-367 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References