Vulnerability · Published Jun 7, 2021 · Assigned by GitHub_M

CVE-2021-32671XSS vulnerability with translator

Critical 10.0

In plain English

A critical-severity cross-site scripting in core from flarum. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 40.0% (higher than 99% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)40.0%top 1.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Flarum is a forum software for building communities. Flarum's translation system allowed for string inputs to be converted into HTML DOM nodes when rendered. This change was made after v0.1.0-beta.16 (our last beta before v1.0.0) and was not noticed or documented. This allowed for any user to type malicious HTML markup within certain user input fields and have this execute on client browsers. The example which led to the discovery of this vulnerability was in the forum search box. Entering faux-malicious HTML markup, such as <script>alert('test')</script> resulted in an alert box appearing on the forum. This attack could also be modified to perform AJAX requests on behalf of a user, possibly deleting discussions, modifying their settings or profile, or even modifying settings on the Admin panel if the attack was targetted towards a privileged user. All Flarum communities that run flarum v1.0.0 or v1.0.1 are impacted. The vulnerability has been fixed and published as flarum/core v1.0.2. All communities running Flarum v1.0 have to upgrade as soon as possible to v1.0.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistflarum/core1.0.2GHSA-5qjq-69w6-fg57

Affected products (as reported)

VendorProductVersions
flarum core >= 1.0.0, < 1.0.2

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

References