Vulnerability · Published Jun 4, 2021 · Assigned by GitHub_M
CVE-2021-32641Reflected XSS when using flashMessages
High 8.1
In plain English
A high-severity cross-site scripting in lock from auth0. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
auth0-lock is Auth0's signin solution. Versions of nauth0-lock before and including `11.30.0` are vulnerable to reflected XSS. An attacker can execute arbitrary code when the library's `flashMessage` feature is utilized and user input or data from URL parameters is incorporated into the `flashMessage` or the library's `languageDictionary` feature is utilized and user input or data from URL parameters is incorporated into the `languageDictionary`. The vulnerability is patched in version 11.30.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | auth0-lock | 11.30.1 | GHSA-jr3j-whm4-9wwm |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/auth0/lock/security/advisories/GHSA-jr3j-whm4-9wwm x_refsource_CONFIRM
- https://github.com/auth0/lock/commit/d139cf01c8234b07caf265e051f39d3eab08f7ed x_refsource_MISC
- https://github.com/auth0/lock/releases/tag/v11.30.1 x_refsource_MISC