Vulnerability · Published May 20, 2021 · Assigned by GitHub_M
CVE-2021-32632CSRF allowing modification of commands, modules, banphrases through hidden iFrames
Low 2.4
In plain English
A low-severity cross-site request forgery in pajbot from pajbot. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities).
Severity (CVSS 3.1)2.4Low
Exploit odds (30 days)0.6%top 51.8% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
Pajbot is a Twitch chat bot. Pajbot versions prior to 1.52 are vulnerable to cross-site request forgery (CSRF). Hosters of the bot should upgrade to `v1.52` or `stable` to install the patch or, as a workaround, can add one modern dependency.
Affected products (as reported)
Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
References
- https://github.com/pajbot/pajbot/security/advisories/GHSA-wmfr-qrg4-qc3h x_refsource_CONFIRM
- https://gist.github.com/Melonify/d8e5d70cdc1bebb871f72dc79d69ac60 x_refsource_MISC
- https://github.com/pajbot/pajbot/releases/tag/v1.52 x_refsource_MISC