Vulnerability · Published Jan 25, 2021 · Assigned by redhat

CVE-2021-3185

Critical 9.8

In plain English

A critical-severity buffer overflow in gstreamer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.5% (higher than 85% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)2.5%top 15.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A flaw was found in the gstreamer h264 component of gst-plugins-bad before v1.18.1 where when parsing a h264 header, an attacker could cause the stack to be smashed, memory corruption and possibly code execution.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12gst-plugins-bad1.01.18.1-1DEBIAN-CVE-2021-3185
Debian:13gst-plugins-bad1.01.18.1-1DEBIAN-CVE-2021-3185
Debian:14gst-plugins-bad1.01.18.1-1DEBIAN-CVE-2021-3185

Affected products (as reported)

VendorProductVersions
n/a gstreamer Fixed in gst-plugins-bad-1.18.1

Weakness: CWE-120

References