Vulnerability · Published May 4, 2021 · Assigned by GitHub_M

CVE-2021-29477Vulnerability in the STRALGO LCS command

High 7.5

In plain English

A high-severity integer overflow in redis from redis. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 4.0% (higher than 91% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)4.0%top 9.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Redis is an open source (BSD licensed), in-memory data structure store, used as a database, cache, and message broker. An integer overflow bug in Redis version 6.0 or newer could be exploited using the `STRALGO LCS` command to corrupt the heap and potentially result with remote code execution. The problem is fixed in version 6.2.3 and 6.0.13. An additional workaround to mitigate the problem without patching the redis-server executable is to use ACL configuration to prevent clients from using the `STRALGO LCS` command.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12redis5:6.0.13-1DEBIAN-CVE-2021-29477
Debian:13redis5:6.0.13-1DEBIAN-CVE-2021-29477
Debian:14redis5:6.0.13-1DEBIAN-CVE-2021-29477
Rocky Linux:8redis0:6.0.9-3.module+el8.4.0+395+8d498eebRLSA-2021:2034

Affected products (as reported)

VendorProductVersions
redis redis >= 6.2.0, < 6.2.3>= 6.0.0, < 6.0.13

Weakness: CWE-190 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References