Vulnerability · Published Apr 13, 2021 · Assigned by GitHub_M
CVE-2021-29438Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in @nextcloud/dialogs
Medium 4.6
In plain English
A medium-severity cross-site scripting in nextcloud-dialogs from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The Nextcloud dialogs library (npm package @nextcloud/dialogs) before 3.1.2 insufficiently escaped text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. The vulnerability has been patched in version 3.1.2 If you need to display HTML in the toast, explicitly pass the `options.isHTML` config flag.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @nextcloud/dialogs | 3.1.2 | GHSA-g3fq-3v3g-mh32 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | nextcloud-dialogs | < 3.1.2 |
Weakness: CWE-79, CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
References
- https://github.com/nextcloud/nextcloud-dialogs/security/advisories/GHSA-g3fq-3v3g-mh32 x_refsource_CONFIRM
- https://www.npmjs.com/package/%40nextcloud/dialogs x_refsource_MISC