Vulnerability · Published Apr 13, 2021 · Assigned by GitHub_M

CVE-2021-29435Cross-Site Request Forgery (CSRF) in trestle-auth

High 8.1

In plain English

A high-severity cross-site request forgery in trestle-auth from TrestleAdmin. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.7%top 48.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

trestle-auth is an authentication plugin for the Trestle admin framework. A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials. The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemstrestle-auth0.4.2GHSA-h8hx-2c5r-32cf

Affected products (as reported)

VendorProductVersions
TrestleAdmin trestle-auth >= 0.4.0, < 0.4.2

Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

References