Vulnerability · Published Apr 13, 2021 · Assigned by GitHub_M

CVE-2021-29428Local privilege escalation through system temporary directory

High 8.8

In plain English

A high-severity security flaw in gradle from gradle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities).

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.5%top 54.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

In Gradle before version 7.0, on Unix-like systems, the system temporary directory can be created with open permissions that allow multiple users to create and delete files within it. Gradle builds could be vulnerable to a local privilege escalation from an attacker quickly deleting and recreating files in the system temporary directory. This vulnerability impacted builds using precompiled script plugins written in Kotlin DSL and tests for Gradle plugins written using ProjectBuilder or TestKit. If you are on Windows or modern versions of macOS, you are not vulnerable. If you are on a Unix-like operating system with the "sticky" bit set on your system temporary directory, you are not vulnerable. The problem has been patched and released with Gradle 7.0. As a workaround, on Unix-like operating systems, ensure that the "sticky" bit is set. This only allows the original user (or root) to delete a file. If you are unable to change the permissions of the system temporary directory, you can move the Java temporary directory by setting the System Property `java.io.tmpdir`. The new path needs to limit permissions to the build user only. For additional details refer to the referenced GitHub Security Advisory.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12gradleno fix listedDEBIAN-CVE-2021-29428
Debian:13gradleno fix listedDEBIAN-CVE-2021-29428
Debian:14gradleno fix listedDEBIAN-CVE-2021-29428
Ubuntu:22.04:LTSgradleno fix listedUBUNTU-CVE-2021-29428
Ubuntu:24.04:LTSgradleno fix listedUBUNTU-CVE-2021-29428
Ubuntu:25.10gradleno fix listedUBUNTU-CVE-2021-29428
Ubuntu:26.04:LTSgradleno fix listedUBUNTU-CVE-2021-29428
Ubuntu:26.10gradleno fix listedUBUNTU-CVE-2021-29428

Affected products (as reported)

VendorProductVersions
gradle gradle < 7.0

Weakness: CWE-379, CWE-378 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

References