Vulnerability · Published May 2, 2021 · Assigned by apache

CVE-2021-28359Apache Airflow Reflected XSS via Origin Query Argument in URL

Medium 6.1

In plain English

A medium-severity security flaw in Apache Airflow from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 14.4% (higher than 97% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)6.1Medium
Exploit odds (30 days)14.4%top 3.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions <1.10.15 in 1.x series and affects 2.0.0 and 2.0.1 and 2.x series. This is the same as CVE-2020-13944 & CVE-2020-17515 but the implemented fix did not fix the issue completely. Update to Airflow 1.10.15 or 2.0.2. Please also update your Python version to the latest available PATCH releases of the installed MINOR versions, example update to Python 3.6.13 if you are on Python 3.6. (Those contain the fix for CVE-2021-23336 https://nvd.nist.gov/vuln/detail/CVE-2021-23336).

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-airflow1.10.15GHSA-3xxv-p78r-4fc6
PyPIapache-airflow2.0.2GHSA-3xxv-p78r-4fc6
PyPIapache-airflow1.10.15, 2.0.2PYSEC-2021-4

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Airflow Apache Airflow 2.0.0Apache Airflow 2.0.1Apache Airflow – before 1.10.15

References