Vulnerability · Published Sep 23, 2021 · Assigned by hackerone
CVE-2021-22948
High 7.1
In plain English
A high-severity cross-site scripting in https://github.com/revive-adserver/revive-adserver. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.7% (higher than 86% of all known vulnerabilities).
Severity (CVSS NVD)7.1High
Exploit odds (30 days)2.7%top 13.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
Vulnerability in the generation of session IDs in revive-adserver < 5.3.0, based on the cryptographically insecure uniqid() PHP function. Under some circumstances, an attacker could theoretically be able to brute force session IDs in order to take over a specific account.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| n/a | https://github.com/revive-adserver/revive-adserver | Fixed version v5.3.0 |
Weakness: CWE-79
References
- https://hackerone.com/reports/1187820 x_refsource_MISC
- https://www.revive-adserver.com/security/revive-sa-2021-005/ x_refsource_MISC