Vulnerability · Published Jun 11, 2021 · Assigned by hackerone

CVE-2021-22904

High 7.5

In plain English

A high-severity uncontrolled resource consumption in https://github.com/rails/rails. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 4.9% (higher than 92% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)4.9%top 7.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The actionpack ruby gem before 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 suffers from a possible denial of service vulnerability in the Token Authentication logic in Action Controller due to a too permissive regular expression. Impacted code uses `authenticate_or_request_with_http_token` or `authenticate_with_http_token` for request authentication.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rails2:6.0.3.7+dfsg-1DEBIAN-CVE-2021-22904
Debian:13rails2:6.0.3.7+dfsg-1DEBIAN-CVE-2021-22904
Debian:14rails2:6.0.3.7+dfsg-1DEBIAN-CVE-2021-22904
RubyGemsactionpack5.2.4.6GHSA-7wjx-3g7j-8584
RubyGemsactionpack6.0.3.7GHSA-7wjx-3g7j-8584
RubyGemsactionpack6.1.3.2GHSA-7wjx-3g7j-8584
RubyGemsactionpack5.2.6GHSA-7wjx-3g7j-8584
Ubuntu:24.04:LTSrailsno fix listedUBUNTU-CVE-2021-22904
Ubuntu:25.10railsno fix listedUBUNTU-CVE-2021-22904
Ubuntu:26.04:LTSrailsno fix listedUBUNTU-CVE-2021-22904
Ubuntu:26.10railsno fix listedUBUNTU-CVE-2021-22904

Affected products (as reported)

VendorProductVersions
n/a https://github.com/rails/rails Fixed in 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6

Weakness: CWE-400

References