Vulnerability · Published Jun 11, 2021 · Assigned by hackerone

CVE-2021-22902

High 7.5

In plain English

A high-severity uncontrolled resource consumption in https://github.com/rails/rails. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.9% (higher than 87% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)2.9%top 13.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The actionpack ruby gem (a framework for handling and responding to web requests in Rails) before 6.0.3.7, 6.1.3.2 suffers from a possible denial of service vulnerability in the Mime type parser of Action Dispatch. Carefully crafted Accept headers can cause the mime type parser in Action Dispatch to do catastrophic backtracking in the regular expression engine.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rails2:6.0.3.7+dfsg-1DEBIAN-CVE-2021-22902
Debian:13rails2:6.0.3.7+dfsg-1DEBIAN-CVE-2021-22902
Debian:14rails2:6.0.3.7+dfsg-1DEBIAN-CVE-2021-22902
RubyGemsactionpack6.0.3.7GHSA-g8ww-46x2-2p65
RubyGemsactionpack6.1.3.2GHSA-g8ww-46x2-2p65
Ubuntu:24.04:LTSrailsno fix listedUBUNTU-CVE-2021-22902
Ubuntu:25.10railsno fix listedUBUNTU-CVE-2021-22902
Ubuntu:26.04:LTSrailsno fix listedUBUNTU-CVE-2021-22902
Ubuntu:26.10railsno fix listedUBUNTU-CVE-2021-22902

Affected products (as reported)

VendorProductVersions
n/a https://github.com/rails/rails Fixed in 6.0.3.7, 6.1.3.2

Weakness: CWE-400

References