Actively exploited · Published May 27, 2021 · Assigned by hackerone

CVE-2021-22894

High 8.8 Exploited

In plain English

A high-severity code injection in Pulse Connect Secure. Attackers are actively exploiting it in the wild (listed by CISA on November 3, 2021). The chance it is exploited in the next 30 days is estimated at 41.3% (higher than 99% of all known vulnerabilities). Apply updates per vendor instructions.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)41.3%top 1.3% of all CVEs
Exploited in the wildYesCISA KEV since Nov 3, 2021
Attack toolingNoneno public tooling known

CISA guidance

Apply updates per vendor instructions.

Federal agencies must remediate by May 3, 2022.

Official description

A buffer overflow vulnerability exists in Pulse Connect Secure before 9.1R11.4 allows a remote authenticated attacker to execute arbitrary code as the root user via maliciously crafted meeting room.

Affected products (as reported)

VendorProductVersions
n/a Pulse Connect Secure Fixed version 9.1R11.4

Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References