Vulnerability · Published Mar 15, 2021 · Assigned by redhat

CVE-2021-20283

Medium 4.3

In plain English

A medium-severity incorrect authorization in moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)4.3Medium
Exploit odds (30 days)1.1%top 33.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistmoodle/moodle3.10.2GHSA-2m72-m5cw-3g9h
Packagistmoodle/moodle3.9.5GHSA-2m72-m5cw-3g9h
Packagistmoodle/moodle3.8.8GHSA-2m72-m5cw-3g9h
Packagistmoodle/moodle3.5.17GHSA-2m72-m5cw-3g9h

Affected products (as reported)

VendorProductVersions
n/a moodle Fixed in 3.10.2, 3.9.5, 3.8.8, 3.5.17

Weakness: CWE-863

References