Vulnerability · Published Mar 15, 2021 · Assigned by redhat

CVE-2021-20282

Medium 5.3

In plain English

A medium-severity incorrect authorization in moodle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)5.3Medium
Exploit odds (30 days)1.3%top 29.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

When creating a user account, it was possible to verify the account without having access to the verification email link/secret in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistmoodle/moodle3.5.17GHSA-grj4-g57c-9xmv
Packagistmoodle/moodle3.8.8GHSA-grj4-g57c-9xmv
Packagistmoodle/moodle3.9.5GHSA-grj4-g57c-9xmv
Packagistmoodle/moodle3.10.2GHSA-grj4-g57c-9xmv

Affected products (as reported)

VendorProductVersions
n/a moodle Fixed in 3.10.2, 3.9.5, 3.8.8, 3.5.17

Weakness: CWE-863

References