Vulnerability · Published Apr 27, 2020 · Assigned by apache

CVE-2020-9488

Low 3.7

In plain English

A low-severity improper certificate validation in Apache Log4j from Apache. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 8.2% (higher than 95% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)8.2%top 5.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Improper validation of certificate with host mismatch in Apache Log4j SMTP appender. This could allow an SMTPS connection to be intercepted by a man-in-the-middle attack which could leak any log messages sent through that appender. Fixed in Apache Log4j 2.12.3 and 2.13.1

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12apache-log4j22.13.3-1DEBIAN-CVE-2020-9488
Debian:13apache-log4j22.13.3-1DEBIAN-CVE-2020-9488
Debian:14apache-log4j22.13.3-1DEBIAN-CVE-2020-9488
Mavenorg.apache.logging.log4j:log4j2.13.2GHSA-vwqq-5vrc-xw9h
Mavenorg.apache.logging.log4j:log4j2.12.3GHSA-vwqq-5vrc-xw9h
Mavenorg.apache.logging.log4j:log4j2.3.2GHSA-vwqq-5vrc-xw9h
Mavenorg.apache.logging.log4j:log4j-core2.3.2GHSA-vwqq-5vrc-xw9h
Mavenorg.apache.logging.log4j:log4j-core2.12.3GHSA-vwqq-5vrc-xw9h
Mavenorg.apache.logging.log4j:log4j-core2.13.2GHSA-vwqq-5vrc-xw9h

Affected products (as reported)

VendorProductVersions
Apache Apache Log4j log4j-core 2.13.0log4j-core – before 2.12.3

Weakness: CWE-295 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

References