Vulnerability · Published Aug 30, 2020 · Assigned by hackerone

CVE-2020-8244

Medium 6.5

In plain English

A medium-severity security flaw in bl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)6.5Medium
Exploit odds (30 days)2.1%top 18.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1, <2.2.1, and <1.2.3 which could allow an attacker to supply user input (even typed) that if it ends up in consume() argument and can become negative, the BufferList state can be corrupted, tricking it into exposing uninitialized memory via regular .slice() calls.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-bl4.0.3-1DEBIAN-CVE-2020-8244
Debian:13node-bl4.0.3-1DEBIAN-CVE-2020-8244
Debian:14node-bl4.0.3-1DEBIAN-CVE-2020-8244
npmbl1.2.3GHSA-pp7h-53gx-mx7r
npmbl4.0.3GHSA-pp7h-53gx-mx7r
npmbl2.2.1GHSA-pp7h-53gx-mx7r
npmbl3.0.1GHSA-pp7h-53gx-mx7r

Affected products (as reported)

VendorProductVersions
n/a bl Fixed in 4.0.3, 3.0.1, 2.2.1, and 1.2.3

Weakness: CWE-126

References