Vulnerability · Published Jul 20, 2020 · Assigned by hackerone

CVE-2020-8205

High 7.5

In plain English

A high-severity server-side request forgery in uppy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 68% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)1.2%top 31.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The uppy npm package < 1.13.2 and < 2.0.0-alpha.5 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external networks or otherwise interact with internal systems.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@uppy/companion1.13.2GHSA-9m4x-8w29-r78g
npm@uppy/companion2.0.0-alpha.5GHSA-9m4x-8w29-r78g

Affected products (as reported)

VendorProductVersions
n/a uppy Fixed Versions: 1.13.2, 2.0.0-alpha.5

Weakness: CWE-918

References