Vulnerability · Published May 15, 2020 · Assigned by hackerone

CVE-2020-8149

Critical 9.8

In plain English

A critical-severity code injection in logkitty. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.0% (higher than 81% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)2.0%top 19.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Lack of output sanitization allowed an attack to execute arbitrary shell commands via the logkitty npm package before version 0.7.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmlogkitty0.7.1GHSA-v8v8-6859-qxm4

Affected products (as reported)

VendorProductVersions
n/a logkitty Fixed Version: 0.7.1

Weakness: CWE-94

References