Vulnerability · Published Mar 20, 2020 · Assigned by hackerone

CVE-2020-8135

Critical 9.8

In plain English

A critical-severity server-side request forgery in uppy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)1.3%top 28.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

The uppy npm package < 1.9.3 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external network or otherwise interact with internal systems.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@uppy/companion1.9.3GHSA-mm7r-265w-jv6f

Affected products (as reported)

VendorProductVersions
n/a uppy Fixed Version: 1.9.3

Weakness: CWE-918

References