Vulnerability · Published Feb 4, 2020 · Assigned by hackerone

CVE-2020-8124

Medium 5.3

In plain English

A medium-severity improper input validation in url-parse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 77% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)5.3Medium
Exploit odds (30 days)1.7%top 23.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-url-parse1.4.7-1DEBIAN-CVE-2020-8124
Debian:13node-url-parse1.4.7-1DEBIAN-CVE-2020-8124
Debian:14node-url-parse1.4.7-1DEBIAN-CVE-2020-8124
npmurl-parse1.4.5GHSA-46c4-8wrp-j99v

Affected products (as reported)

VendorProductVersions
n/a url-parse Fixed Version 1.4.5

Weakness: CWE-20

References