Vulnerability · Published Mar 10, 2020 · Assigned by GitHub_M
CVE-2020-5253Privilege escalation in NetHack
Low 3.9
In plain English
A low-severity security flaw in NetHack from NetHack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)3.9Low
Exploit odds (30 days)0.5%top 54.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
NetHack before version 3.6.0 allowed malicious use of escaping of characters in the configuration file (usually .nethackrc) which could be exploited. This bug is patched in NetHack 3.6.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | nethack | 3.6.0-1 | DEBIAN-CVE-2020-5253 |
| Debian:13 | nethack | 3.6.0-1 | DEBIAN-CVE-2020-5253 |
| Debian:14 | nethack | 3.6.0-1 | DEBIAN-CVE-2020-5253 |
Affected products (as reported)
Weakness: CWE-184 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N