Vulnerability · Published Feb 24, 2020 · Assigned by GitHub_M
CVE-2020-5244Private data exposure via REST API in BuddyPress
High 8.0
In plain English
A high-severity improper access control in BuddyPress from buddypress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.4% (higher than 84% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.0High
Exploit odds (30 days)2.4%top 15.6% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | buddypress/buddypress | 5.1.2 | GHSA-3j78-7m59-r7gv |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| buddypress | BuddyPress | < 5.1.2 |
Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
References
- https://github.com/buddypress/BuddyPress/security/advisories/GHSA-3j78-7m59-r7gv x_refsource_CONFIRM
- https://buddypress.org/2020/01/buddypress-5-1-2/ x_refsource_MISC
- https://github.com/buddypress/BuddyPress/commit/39294680369a0c992290577a9d740f4a2f2c2ca3 x_refsource_MISC