Vulnerability · Published Feb 20, 2020 · Assigned by GitHub_M

CVE-2020-5243Denial of Service in uap-core when processing crafted User-Agent strings

Medium 5.7

In plain English

A medium-severity improper input validation in uap-core from ua-parser. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.3% (higher than 83% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.7Medium
Exploit odds (30 days)2.3%top 16.7% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

uap-core before 0.7.3 is vulnerable to a denial of service attack when processing crafted User-Agent strings. Some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This has been patched in uap-core 0.7.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12uap-core1:0.8.0-1DEBIAN-CVE-2020-5243
Debian:13uap-core1:0.8.0-1DEBIAN-CVE-2020-5243
Debian:14uap-core1:0.8.0-1DEBIAN-CVE-2020-5243
RubyGemsuser_agent_parser2.6.0GHSA-cmcx-xhr8-3w9p
Ubuntu:22.04:LTSuap-coreno fix listedUBUNTU-CVE-2020-5243
Ubuntu:24.04:LTSuap-coreno fix listedUBUNTU-CVE-2020-5243
Ubuntu:25.10uap-coreno fix listedUBUNTU-CVE-2020-5243
Ubuntu:26.04:LTSuap-coreno fix listedUBUNTU-CVE-2020-5243
Ubuntu:26.10uap-coreno fix listedUBUNTU-CVE-2020-5243
npmuap-core0.7.3GHSA-cmcx-xhr8-3w9p

Affected products (as reported)

VendorProductVersions
ua-parser uap-core < 0.7.3

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H

References